Scheduled Maintenance - La Rez, Stellenbosch
Scheduled for July 20, 2025 at 1:00 AM – 3:00 AM
Affects
FibreGeeks
Under maintenance from 1:00 AM to 3:00 AM
Completed
July 20, 2025 at 3:00 AMCompleted
July 20, 2025 at 3:00 AMMaintenance has completed successfully
In progress
July 20, 2025 at 1:00 AMIn progress
July 20, 2025 at 1:00 AMMaintenance is now in progress
Planned
July 20, 2025 at 1:00 AMPlanned
July 20, 2025 at 1:00 AMOur backhaul provider will be performing scheduled maintenance to improve reliability as well as the performance of the current link.
The maintenance has been scheduled for:
Date: 20 July 2025
Time: 03:00 - 05:00 (2 hours)